→(Discussion: Use of iterating variables on for loops): Added feedback
| ammisko || I like option 1 better (I changed it a bit). I think it looks cleaner and is much easier to read for someone who doesn't know what the code does (especially with comments). Also what if we need to use a loop variable from outside the for loop? Or if we need to use the first part of the for-loop for other code? Option 1 could accommodate that better I think.
=== (Discussion: Variable names) ===