Changes

Jump to: navigation, search

OOP344 Temporary

577 bytes added, 23:10, 27 October 2009
OOP344 northWind87: Added coding standards section, more to do soon...
| Sandhu || Charanjit || cssandhu || B || [http://cj-seneca.blogspot.com Blog] || Charanjit|| - || ops344_093svn114
|}
 
== Coding Standards ==
=== Naming Convention ===
* Camel notation should be used for variable names and function names ie myVar, bigInt, getNumber(), myFunction()
* Class names should always be first-letter capitalized ie TestClass, DynamicStack, PeanutButter, Hammer
* Compiler directives should always be written in all lowercase ie #define, #ifndef
* Compiler definitions should be all uppercase IO_CTL_LARGEFILE, SOME_DEFINITION
* Header file defines should be preceeded and followed with two underscores ie __CIOL_H__, __IO_FORM_H__
 
=== Code Blocks ===
...incomplete...
== Announcements ==

Navigation menu