Difference between revisions of "OOP344 - Team Nothing IRC Logs - 20102"

From CDOT Wiki
Jump to: navigation, search
(Chat Logs)
(Chat Logs)
Line 1: Line 1:
 
'''[[OOP344 - Team Nothing - 20102 | Team Nothing]]'''
 
'''[[OOP344 - Team Nothing - 20102 | Team Nothing]]'''
 
=Chat Logs=
 
=Chat Logs=
 +
==30-May-10 Channel: #Team-Nothing==
 
<pre>
 
<pre>
 
Session Start: Sun May 30 19:06:27 2010
 
Session Start: Sun May 30 19:06:27 2010

Revision as of 20:25, 30 May 2010

Team Nothing

Chat Logs

30-May-10 Channel: #Team-Nothing

Session Start: Sun May 30 19:06:27 2010
Session Ident: #team-nothing
[19:06] * Now talking in #team-nothing
[19:06] * barjavel.freenode.net sets mode: +ns
[19:07] -> *chanserv* help register
[19:09] * sinker (~sinker@CPE002129c879f5-CM0014e826c482.cpe.net.cable.rogers.com) has joined #team-nothing
[19:09] * acchung1 sets mode: +o sinker
[19:09] * acchung1 sets mode: +v acchung1
[19:09] <@acchung1> i think it's better to discuss it here since fardad isn't here
[19:10] <@acchung1> not necessary for other people to see our discussion
[19:10] * danapao (~chatzilla@CPE001cf0f6cc86-CM0011ae9081e8.cpe.net.cable.rogers.com) has joined #team-nothing
[19:10] <@sinker> do you prefer underscores or capitals, ie, some_function or someFunction?
[19:10] <@acchung1> i prefer the 2nd
[19:11] <danapao> senond
[19:11] <danapao> then for variables ...we can do prof way saying
[19:11] <danapao> int a;
[19:11] <danapao> int b;
[19:11] <@acchung1> Spacing wise i don't mind... I was taught to do 3 spaces
[19:11] <@acchung1> spacing as in indent
[19:13] <@acchung1> who else are we missing?
[19:13] <@sinker> i prefer the second way too but fardad's function names use underscores, so do you want to use underscores for functions and the other way for variables?
[19:13] <@acchung1> hm
[19:14] <@acchung1> Sure, I don't have any problem with that
[19:14] <@acchung1> Function: This_Function
[19:14] <@acchung1> Variable: thisVariable
[19:14] <@acchung1> like that right?
[19:14] <@sinker> yeah but all lowercase for the functions
[19:15] <@acchung1> ah all lowercase
[19:15] <@acchung1> k
[19:15] <danapao> ok
[19:15] <@acchung1> i have no problem with that
[19:15] <@sinker> that way we can easily identify a function vs. a variable name
[19:15] <danapao> true
[19:16] <@sinker> some_function and someVariable
[19:16] <@acchung1> alright
[19:18] <danapao> k
[19:18] <@acchung1> so all variables are the same or should we do something different with public and private variables?
[19:19] <@sinker> all the same would be simpler
[19:19] <@acchung1> alright
[19:19] <danapao> agree
[19:21] <@acchung1> alright how about indenting?
[19:21] <@acchung1> i usually use 3 spaces
[19:22] <@sinker> i'm ok with 3
[19:22] <danapao> im ok with 3
[19:22] <@acchung1> alright
[19:23] <danapao> did u guys got ur accounts?
[19:23] <@sinker> no
[19:23] <@acchung1> nope
[19:24] <danapao> ok
[19:24] <@acchung1> robin is on
[19:24] <@acchung1> how about commenting?
[19:25] * imadorki3 (~androirc@24.114.232.38) has joined #team-nothing
[19:25] <@acchung1> hi
[19:25] <imadorki3> hii
[19:26] <imadorki3> is he going to be on?
[19:26] <@acchung1> so basically since fardad isn't here, we are discussing about the rules and conventions we will be using when we are coding
[19:26] <@acchung1> doubt it
[19:26] <@acchung1> but we are using this time to do the rules and conventions
[19:26] <imadorki3> this is lame! blahh..
[19:26] <@acchung1> lol
[19:27] <@acchung1> well we need to do this before we start working on the project, the sooner we have it done the better
[19:27] <imadorki3> ohhkay sounds good
[19:27] <@acchung1> so basically
[19:27] <@acchung1> we did some stuff
[19:27] <@sinker> imadorki3: do you want to discuss how to bake a cake? :)
[19:27] <@acchung1> lol
[19:28] <imadorki3> I think ill pass with the cake baking lol
[19:28] <@acchung1> Function Naming Convention: int function_name()
[19:28] <@acchung1> imadorki3: any problems with that?
[19:29] <imadorki3> nopee
[19:29] <@acchung1> ok
[19:29] <@acchung1> for variable we did
[19:29] <@acchung1> variableName
[19:29] <@acchung1> and each variable will be on it's own line
[19:29] <@acchung1> int a;
[19:29] <@acchung1> int b;
[19:29] <@acchung1> indentation wise, we said we are going to use 3 spaces
[19:30] <@acchung1> any objections?
[19:30] <imadorki3> sounds good so far: )
[19:30] <@acchung1> okay
[19:30] <@sinker> or just var if it's a simple variable name like cat or dog
[19:30] <@acchung1> yep
[19:31] <@sinker> varName for compound variable names
[19:31] <imadorki3> yessirs!
[19:31] <@acchung1> k
[19:31] <@acchung1> so on to commenting
[19:32] <@acchung1> the file heading
[19:33] <imadorki3> what format do you guys want to use?
[19:33] <@acchung1> I usually do this
[19:33] <@acchung1>  * File Name: example.cpp
[19:33] <@acchung1>  * Author: Name (senecaid)
[19:33] <@acchung1>  * Create Date: 23-May-10
[19:33] <@acchung1>  * Last Modified Date: 11-Nov-10
[19:33] <@acchung1>  * Description: blah blah blah
[19:33] <@acchung1>  */
[19:33] * danapao_ (~chatzilla@CPE001cf0f6cc86-CM0011ae9081e8.cpe.net.cable.rogers.com) has joined #team-nothing
[19:33] <@acchung1> lol
[19:33] <danapao_> i got kick out
[19:33] <@acchung1> nice
[19:33] <@acchung1> you're still here for me
[19:34] * Retrieving #team-nothing modes...
[19:34] * acchung1 sets mode: +t-n
[19:34] <@acchung1> What was that site that fardad used for copy and paste?
[19:35] <@sinker> pastebin.com
[19:35] <imadorki3> what about individual comments per function?
[19:35] <@acchung1> thanks
[19:35] <imadorki3> that's a good idea, I'm not takibg note of this: )
[19:35] <@acchung1> http://pastebin.com/Ns3REB7p
[19:36] <@acchung1> don't worry i am
[19:36] <@acchung1> i got the chat log and i'm doing the wiki as we are agreeing on things
[19:36] * danapao (~chatzilla@CPE001cf0f6cc86-CM0011ae9081e8.cpe.net.cable.rogers.com) Quit (Ping timeout: 276 seconds�)
[19:36] * danapao_ is now known as danapao
[19:36] <@sinker> that looks ok for file headers
[19:37] <imadorki3> kayyy cause I'm on irc on my phone :S
[19:37] <imadorki3> agreed
[19:37] <@acchung1> http://pastebin.com/NTSfJTgx for each function
[19:37] <danapao> my irc server is acting weird
[19:37] <@acchung1> i don't think we should comment each line, instead we should just comment the function
[19:38] <imadorki3> yeahh agreed
[19:38] <@acchung1> because i think we should more or less understand the lines if we know what the function does
[19:38] <imadorki3> that's what I did
[19:38] <danapao> k agree
[19:38] <@acchung1> k
[19:38] <@acchung1> kerry?
[19:38] <@acchung1> er
[19:38] <@acchung1> sinker?
[19:38] <@acchung1> sinker: any problems?
[19:38] <@sinker> agree
[19:39] <@acchung1> k
[19:39] <danapao> so thats it?
[19:39] <@acchung1> one more that i can think of
[19:39] <@sinker> I suggest comments to describe functions and purpose of variable
[19:40] <@acchung1> purpose of variable?
[19:40] <@acchung1> ex?
[19:41] <@sinker> what the variable will be used for or what it will contain
[19:41] <@sinker> i don't mean the type
[19:42] <imadorki3>  I think that having the purpose of each function is good enough, as well, following the purpose of te fuction rhere should be a list of variables used within that function
[19:42] <@sinker> in the comments?
[19:42] <@acchung1> sinker: I get what you mean... but do we put the meaning of the variable comment beside the variables or in the commenting block of each function?
[19:42] <imadorki3> eg. function name
[19:43] <imadorki3> purpose
[19:43] <@acchung1> so in the purpose
[19:43] <imadorki3> variables in function
[19:43] <@acchung1> AH
[19:43] <imadorki3> purpose
[19:43] <imadorki3> yeah
[19:43] <imadorki3> function comment block
[19:43] <@acchung1> ok
[19:44] <@acchung1> http://pastebin.com/L2vvT8Bm
[19:44] <@sinker> ok we can state the purpose of the variable as we name them in the function comments
[19:44] <@acchung1> something like that?
[19:44] <@acchung1> http://pastebin.com/vFGUw0PH
[19:44] <@sinker> yeah, ok
[19:44] <@acchung1> ?
[19:45] <danapao> yep
[19:45] <imadorki3> sorry guys I'm typing on my phone and ny thumbsare starting to hurt
[19:46] <@sinker> how about this style for braces { }  http://pastebin.com/fCrsvVzS
[19:46] <imadorki3> I can't see the link
[19:46] <imadorki3> or rather I can't click on the links
[19:46] <@acchung1> lol
[19:46] <@sinker> imadorki3: lol
[19:46] <@acchung1> Look on the wiki
[19:46] <@acchung1> i'll save it now
[19:46] <imadorki3> I canttttt
[19:47] <imadorki3> I'm on my phone I can't go on lol
[19:47] <@acchung1> lol
[19:47] <@sinker> imadorki3: look later :)
[19:47] <@acchung1> well check later
[19:47] <@acchung1> yep
[19:47] <imadorki3> okayyy sounds good
[19:47] <@acchung1> Sinker: I actually prefer something different
[19:47] <imadorki3> what else is there...hmm
[19:48] <@acchung1> http://pastebin.com/qQYFa8cA
[19:48] <@acchung1> i prefer that
[19:48] <@acchung1> so it is easier to see when it opens and closes
[19:48] <@acchung1> also so that we won't "miss" a brace
[19:48] <danapao> good idea
[19:49] <@sinker> acchung1: ok, that's true about keeping track of open and close
[19:49] <danapao> is there anything else because i g2g in a few mins?
[19:50] <@acchung1> hm
[19:50] <@acchung1> if it is 1 line should we use the {}?
[19:50] <@acchung1> always use it is my answer but i want to see what you guys think
[19:51] <@sinker> i'm having second thoughts about the var naming. should we keep it similar to the function naming?
[19:52] <imadorki3> I like to use the braces regardless, its just easier to read I think..
[19:52] <@acchung1> ookay
[19:52] <@sinker> acchung1: for one line you don't really need it but we can use them just in case more code gets added later...
[19:52] <@acchung1> so always use it
[19:53] <@sinker> that way they don't get forgotten
[19:53] <@acchung1> okay
[19:53] <@acchung1> and i don't mind for the variables
[19:53] <@acchung1> either way is fine
[19:54] <@sinker> ok let's do it similar to the functions so our code looks cleaner and more consistent
[19:54] <@acchung1> alright
[19:54] <@acchung1> any objections?
[19:54] <danapao> nope
[19:55] <imadorki3> yes
[19:55] <imadorki3> no I'm joking
[19:55] <@sinker> one other thing..
[19:55] <imadorki3> lol
[19:55] <imadorki3> yess?
[19:55] <@sinker> naming for conditional comolation
[19:55] <@sinker> compilation
[19:56] <@acchung1> ?
[19:56] <imadorki3> I'm just as confused lol.
[19:56] <@sinker> in the course notes they give an example: #define _abc_h_
[19:57] <danapao> whats that?
[19:57] <@acchung1> the thing fardad did?
[19:57] <@acchung1> i think i'm getting sick lol
[19:57] <@sinker> yeah
[19:57] <@acchung1> freezing, brb
[19:57] <@sinker> we can talk about that one later
[19:57] <danapao> o that #ifndef _HEADER_H
[19:58] <danapao> then blah
[19:58] <danapao> i google it to find out what u mean
[19:58] <@sinker> yeah, to make it something unique
[19:58] <@acchung1> lol
[19:58] <imadorki3> how did you want to name it?
[19:58] <@sinker> see page 11 in the notes if you have them
[19:58] <@acchung1> i like the _header_h
[19:59] <imadorki3> ill check it out later I guess
[19:59] <danapao> lol
[19:59] <imadorki3> :)
[19:59] <@acchung1> lol
[19:59] <@acchung1> should i register this channel?
[19:59] <@sinker> i was thinking of using our team initials in it somehow to make it unique
[19:59] <@acchung1> _tn_header_h
[19:59] <@acchung1> ?
[19:59] <danapao> yeah
[20:00] <danapao> thats a good idea
[20:00] <@acchung1> or _TN_header_h
[20:00] <@acchung1> or all caps
[20:00] <@sinker> yeah but with an underscore at the end too
[20:00] <@sinker> i think lowercase
[20:00] <@sinker> all lowercase
[20:01] <danapao> ok kids ( even tough i might be the youngest) i g2g
[20:01] <@sinker> _tn_headerabc_h_
[20:01] <@acchung1> alright
[20:01] <@acchung1> danapao: later
[20:01] <@sinker> danapao: bye
[20:02] * danapao (~chatzilla@CPE001cf0f6cc86-CM0011ae9081e8.cpe.net.cable.rogers.com) Quit (Quit: ChatZilla 0.9.86 [Firefox 3.6.3/20100401080539]�)
[20:02] <@acchung1> so anything else?
[20:02] <@sinker> i that's good for now
[20:03] <@acchung1> alright
[20:03] <imadorki3> I thi k I need to go now too, time to go home: ) ill check this convo out later once I get home, so I have a better idea of what you guys are talking about!
[20:03] <@acchung1> bye
[20:03] <@sinker> acchung1: can you add your suggestions for coding style to the team wiki?
[20:03] <imadorki3> byeeee!
[20:03] <@acchung1> doign it right now
[20:04] <@acchung1> imadorki3: bye
[20:04] <@sinker> imadorki3: bye
[20:04] * imadorki3 (~androirc@24.114.232.38) Quit (Quit: Bye�)
[20:04] <@acchung1> it should be up in a few once i do the conditional thing
[20:04] <@sinker> acchung1: are you adding everything we talked about?
[20:05] <@acchung1> yep
[20:05] <@acchung1> this will go intot he irc chat log
[20:05] <@sinker> acchung1: ok, thanks..did you create a log file?
[20:05] <@acchung1> yep
[20:06] <@sinker> acchung1: i'm going to get going
[20:06] <@acchung1> alright
[20:06] <@acchung1> see you later
[20:07] -> *chanserv* register help
[20:07] <@sinker> i'll see you wed in class
[20:07] <@acchung1> see you wed in class
[20:07] * @sinker (~sinker@CPE002129c879f5-CM0014e826c482.cpe.net.cable.rogers.com) has left #team-nothing
Session Close: Sun May 30 20:08:16 2010